GoPro Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have been charging my GoPro 4 for almost a day but the red light still does not go off. I believe it should have been fully charged after a whole day of charging.

Anyone can help?
 

·
Registered
Joined
·
784 Posts
Hi Weeleong and Welcome to the Forum,

Is the battery a GoPro battery or a third party battery?
Is the camera on while you are charging? Do you have another battery to check and see if this same issue occurs?

Cheers,
Kareem
 

·
Administrator
Joined
·
9,729 Posts
@weeleong87 Welcome to the Forums.

1 battery takes 1 hour to Hit 80%, and an additional hour to complete a slower charge.

2. Where did you have it plugged into?

3 Questions to your questions,? not what you want, we know

FISH
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hi,

I am using the Gopro battery and am charging it using the wall socket.

I do not have another battery to check.
 

·
Administrator
Joined
·
9,729 Posts
Hi,

I am using the Gopro battery and am charging it using the wall socket.

I do not have another battery to check.
like so



please be more specific? why. the charger has different outut
 

·
Administrator
Joined
·
9,729 Posts
If you did not try this do so. Gopro cable, your Puters USB port, report back two hours or less later.

If you are doing aftermarket:

scenerio 1

puter, aftermarket cable failure, its thecable

scenerio 2 gopro cable, aftermarket charger failure its the charger.

scenerio 3 aftermarket cable aftermarket charger failure its can be the cable, thecharger o rboth.

scenerio 4 aftermarket ports. gopro cable.failure port or product

scenerio 5 aftermarket port aftermarket cable failuere port, product, cable.

Some times a cable may not have a correct pin layout, a bent pin, broken pin,

sometimes a port may be sleeping, off, broken.

I suggest checking battery, cable, etc...
 

·
Registered
Joined
·
1,841 Posts
I am guessing the charger is not producing the correct voltage/amperage. It must be 5 Volts at 1 amp. I searched gomatics site and could not find the exact specs but the image below shows the output less volts. I am guessing your charger is incompatible.

I strongly suggest you find a set of wasabi or gopower batteries (as extras) and the charger they come with. Remove the battery from the camera to charge it.
 

Attachments

·
Registered
Joined
·
1 Posts
Using a GoPro cable and battery, and plugging into a mains socket with USB my red light stayed on. Plugging in to a iPad charger, red light went off.

Wall sockets with usb are not ideal ?
 

·
Administrator
Joined
·
9,729 Posts
rated chargers make a whole ot of a difference. fall short of the rating it fails to work. I say but random issues do appear at given times that many never come forward with.

1.0A or higher, as the camera is rated at how many amps less then the rated charger.
 
1 - 11 of 11 Posts
Top