GoPro Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,

I got a new gopro hero 3+ black camera couple days ago. At 1st i took videos and everything was fine, then i wanted to use the wi-fi function so i went and figured out i need to do some sort of an update to set it up with my phone. I did the manual update on gopro website the one that updates firmware and wifi. so i did everything as guide said and in the end my camera was updating and turned off. So i figured that's it, its done.
But then i was unable to turn on camera , i tried hard resets and all the other tricks i found on internet nothing works.

I cant turn on camera however when the battery is inserted in camera, the camera gets hotter as if im using it to shoot videos. When i plug the camera to my PC with or without battery i dont see any lights flash or anything. And sometimes my PC gives me some kind of an Unknown device error.

Anyone has some ideas what this could be and how can i fix this?

Thanks in advance.
 

·
Registered
Joined
·
2 Posts
arturskat,

If the 3 + is new and it did not get wet, it is likely that the update process got corrupted. During an update the camera may appear to turn off then turn on a few times. It is best to watch for the "update complete" screen. One of the nice features of the 3+ is wifi updates, and I have occasionally had some success with a wifi updates even when the 3+ would not appear to respond normally. If you can't it to connect and update with the wifi, call up service and get a replacement camera. They are usually very good about issues with new cameras.

mike in az
 
1 - 2 of 2 Posts
Top