GoPro Forums banner

Hero 10 Files not recognised by Windows 10 PC - Solved

1704 Views 1 Reply 2 Participants Last post by  Fish
Just got my Hero 10 and was a bit disappointed to find that when I connected a USB cable to my laptop to transfer the files, they were not visible. I contacted support but they weren’t able to fix the problem. This is how I fixed it:

1) Manually applied the latest firmware: Thank you GoPro support.

2) Formatted the Sandisk Extreme Pro microsd card using the Hero 10:
Swipe down
Swipe left and choose Preferences
Swipe up and choose Reset
Choose Format SD Card.

Now I can transfer files :)

Formatting the sd card is not really intuitive these days when you can put them into phones or tablets and they just work. And you didn’t have to do that with my previous Hero 6.
If anyone from GoPro reads these posts, then perhaps you might consider putting this in the manual and update the notes that front line support use.
1 - 2 of 2 Posts
glad you resolved your issue, it is good practice to generally format via the camera but the gopros processor can not delete off hidden files in partition 2, why you should be using a computer and a full not quick format, this proceedure has gone on for years,
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.