GoPro Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Couple weeks ago I broke the front LCD on my GoPro Hero 4. The GoPro has been getting pretty banged up. Couple days ago I noticed that my videos do not have sound anymore. I decided to take it apart to check the microphone. I'm very Electronic savvy... So i was confident in doing so. When reassembling the PCB layers/stack the ribbon cable for the record button and the wifi/settings button ripped in half. So I removed the ribbon cable from the connector I figured I will just set the camera up to Auto record.

Upon reassembly the camera will beep 3 times and the red led will bink and is then completely unresponsive... the only way to make it function again is to pull the battery and put it back in. The camera appears to charge the battery normally if I plug it in.

And since the front LCD is broken I can not tell if there is any warning / status indications.

It doesn't seem like the ribbon cable being broken would make any difference. Since all it is doing is detecting when a button is pushed and bringing the contacts. There isn't any "smart" functionality it them...

On the PCB there are tests points for each button so I could install my own "button" but very doubtful it will make any difference... tried to manually update the firmware but the camera still just beeps 3 times and seems to turn off...

Any info would be appreciated
 

·
Administrator
Joined
·
9,023 Posts
IMHO:

you think the cable just tie the on/off nothing more it controls more then that I say. had the same issue with a YI4K and at least tape held my ribbon lock on. go on Ebay and see what parts are available.
 
1 - 2 of 2 Posts
Top