GoPro Forums banner
1 - 3 of 3 Posts

3 Posts
Discussion Starter · #1 ·
Got my H8 over a week. Before open box, I watch some tutorials so am familiar with operations. Out of box, charged up battery, put in card. Turn on, right away I'm in timewarp, with only the icon toggle blue or grey, either recording or not. All horizontal and vertical swipe won't bring me anything or out of timewarp.
Maybe needs a firmware upgrade?
Pair with Quik app, to download firmware upgrade, it says camera busy...
After a while, I'm able to get out of timewarp. Don't know what steps. It operates as expected and It's set to "Last Photo".
Today, it happens again when power on camera alone. Top of the screen, left hand a chip telling capacity, center recording running, right battery status. No icon or any else. Tried "Mode" button got "Highlight added". Pair with Quik, Control camera, don't see stop button. I can swipe left/right to diff mode, but NOT taking control, and camera just keeps recording. Tried for 30 minutes until battery running out.
1 - 3 of 3 Posts