Problems with HERO (2014) and computer connection - GoPro Forum, Classifieds and Support
 
LinkBack Thread Tools Search this Thread
post #1 of 3 Old 11-28-2018, 03:34 AM Thread Starter
Newbie
 
Join Date: Nov 2018
Posts: 2
(Thread Starter)
Problems with HERO (2014) and computer connection

Hi all

I have the 2014 HERO, the basic entry level camera. It is on firmware version 1.09 and has been for a while. Before I "upgraded" to that, the camera was always recognised by my Windows 10 and 7 laptops as a GoPro. Quik and Studio would import media and all was good.

Now the laptops don't see the camera, just charge it. I have to remove the SD card and insert it into the laptops - Quik recognises it and does the importing as usual.

I've spoken to GoPro customer support and they can't help. Is there an older version of FW available? Or a more simple fix? Some new drivers? Any advice would be most welcome.

Thanks for reading!
23deano is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-28-2018, 07:05 AM
Super Moderator
 
Fish's Avatar
 
Join Date: Apr 2012
Location: The Apple
Posts: 8,881
additional to the post: google hte firmware you'll find it. Hero 2014 menaing hte basic low economy model?

here is a link for 1.09 https://www.techspot.com/downloads/d...o-hero-update/

https://www.goproforums.com/82-intro...ng-advice.html

a Slow site is joining and leaving lets make this a better site by staying around and participating.Vsit my
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
[B]& Youtube channel

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

helpful in ways you never know. forgive my working hands I make mistakes...

Last edited by Fish; 11-28-2018 at 07:07 AM.
Fish is offline  
post #3 of 3 Old 12-10-2018, 03:29 AM Thread Starter
Newbie
 
Join Date: Nov 2018
Posts: 2
(Thread Starter)
Yes it the cheapest model available, or was when it was released.
1.09 is the cause of the problems to my knowledge.
I have tried updating using the file you linked to, as per the advice of GoPro support. They also advised me to delete the USB controllers and reinstall, and that didn't help either.
23deano is offline  
Reply

Tags
firmware, hero, windows, windows 10

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the GoPro Forum, Classifieds and Support forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hero 7 and wireless connection Loss fix if you use a promic Fish Hero 7 Black/Silver/White 0 10-09-2018 07:49 PM
GoPro Hero 7 Black re-connection problems with iPhone app Privateer Hero 7 Black/Silver/White 5 10-09-2018 06:52 PM
Hero4 session wifi connection problems Johnny 24 GoPro Hero 5 Session & Hero Session 5 01-12-2016 02:31 PM
problems connecting to smarthone( avoided poor internet connection) jowens GoPro Hero 3, 3+ & 4 0 06-16-2013 12:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome