Run GoPro Hero 4 with NO battery! : Switronix Battery Eliminator VIDEO REVIEW - GoPro Forum, Classifieds and Support
 
LinkBack Thread Tools Search this Thread
post #1 of 1 Old 04-12-2015, 08:40 AM Thread Starter
Administrator
 
Ifti's Avatar
 
Join Date: Nov 2012
Posts: 2,764
(Thread Starter)
Run GoPro Hero 4 with NO battery! : Switronix Battery Eliminator VIDEO REVIEW

This has made its way into my GoPro setup! A great accessory!


See my
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Channel for GoPro Reviews & Tips!

Ifti is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the GoPro Forum, Classifieds and Support forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Similar Threads
Thread Thread Starter Forum Replies Last Post
VIDEO REVIEW - Wasabi Hero 4 Battery Kit! Ifti Video Reviews 0 03-04-2015 01:51 PM
Smatree TRIPLE Charger for Hero 4 + Battery Life Test! - VIDEO REVIEW Ifti Video Reviews 0 01-14-2015 01:49 PM
VIDEO REVIEW: Almost 5 HOURS power on your GoPro! Wasabi 2780mAh Battery! Ifti Video Reviews 3 10-03-2014 01:59 PM
Wasabi Power Battery vs GoPro OEM HERO3 Battery Comaprison & Review GoPronaut GoPro Hero 3, 3+ & 4 17 08-21-2013 10:27 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome