Hero2 won't charge or turn on - GoPro Forum, Classifieds and Support
User Tag List

Reply
 
LinkBack Thread Tools
Old 01-26-2013, 11:52 AM   #1
Junior Member
 
Join Date: Jan 2013
Posts: 1
Default Hero2 won't charge or turn on

Hello!

I have a Hero 2 that went suddenly unresponsive. I hadn't used it in a while and I can't remember if it had a full charge when I stored it or not.
Yesterday I picked it up and tried to charge. Light won't turn on. Tried to turn the camera on, nothing happens. I took the battery out, waited a bit, put it back. Nothing. The camera did turn itself on if plugged into AC without the battery inside.

I went looking online and found this:
It's a user reporting the same behavior. In the comments, YT user hittejoel1 recommends the following steps:

"First remove the battery
2 insert the USB cable into the camera from your computer. the red? light will flash weakly.
3 When the light flashes, stop the battery while the cable is plugged in
4 Now to glow red all the time without blinking
5 wait until the light goes out (may take several hours)
6 When the lights are off, you can start your camera again.
7 Update your camera, the first thing you do before you turn it off!
8 problem should be solved!"

My problem is: the light won't go red when I put the battery on while plugged in. It did this yesterday when I was trying to see what was happening, but now it won't anymore. The light only blinks weakly like the instruction describes. I have the camera plugged through a GoPro issued USB cable and an iPhone AC adapter. It doesn't respond or blink in any way when connected to a computer.

This camera hasn't gone through the update process yet. Could this have caused it to die like this, without being used?

My version on Cineform Studio is 1.3.1.162, on a Macbook. It doesn't recognize the camera right now. I updated another Gopro with it last year and it worked. Should this one wake up again, I might attempt to update it, but I can't do it before the battery charges, right? I tried another (working) battery on it and it didn't respond as well.

Any helpful thoughts? I guess sending it back isn't an option - I live in Brazil and I'm not sure they'll take it back (or if the charges aren't higher than the price of the camera itself ). Search on the forum, as far as I could go, indicates users sending it back, but there weren't many similar situations, if I didn't choose the wrong terms... Anyone has had a different outcome? Please?

------------------------------------------------------
UPDATE: Tried again with another battery, removed battery, plugged into AC (iPhone charger w/ GoPro USB cable), light blinks weakly, put new battery in. Red light is now ON. I will not touch the camera until it goes off, hoping it will be ok to perform the update. I just saw that there was yet another update on Jan 9th this year, so I guess this camera is now two updates behind (the Wifi Bacpac one last year and this new one). Should that be an issue?
notnat is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-16-2013, 03:57 AM   #2
Junior Member
 
Join Date: Mar 2013
Posts: 1
Default Fixed!

I had this exact same problem and the fix above didn't work.

My GoPro Hero2 would blink when plugged in with no battery but not switch to a constant red when I plugged it in.

I have now fixed it.

Without it plugged in but with an SD card inserted I took the battery out and inserted it again repeatedly, each time trying to turn it on until it eventually came on (it took about 25 attempts and I didn't wait long between each one). I then plugged it into the computer, used cineform to download the update onto the SD card. When Cineform told me to disconnect and then power on holding the shutter button, again it would not come on, eventually, this time after 30 attempts it did! I followed the rest of the update instructions and now it seems to be all good.

Hope this helps and good luck

Steve.
Steve Wakeford is offline   Reply With Quote Quick reply to this message
Old 05-26-2013, 06:07 PM   #3
Junior Member
 
Join Date: May 2013
Posts: 1
Default Fixed Mine, finally!!

I have spent about 8 hours over the past 2 weekends trying to get from this firmware version: "HD2.08.12.70"
to
"622"

I am now at ‘622’, but as 8 hours suggests it's been a slog!

As with notnat my Hero2 had been working fine; bought December 2012, used a couple of times to see how it worked (it is my first Hero) stored until April, used once and then got out again in May, when it would not reliably switch on.

Getting a charge was the first major problem.
This is (roughly) what I had to do.

1) remove the battery
2) insert the USB cable into the camera from your computer. the red light will flash weakly. Don’t press ‘P’, if you do start at number 1) again.
3) remove the cable
4) insert the battery
5) connect the cable, the red light glows strongly. If you are lucky.
6) wait...until the battery is charged, the red light goes out. The Hero2 has a charged battery.
6* you may need to have the SD card out for some or all of 1,..,6. This and some advice on YouTube that didn’t work burnt 6hours, not including waiting for the battery to charge!
Getting the charge seems crucial, the numerous failed attempts appear to result in a discharged battery, instantly!

7) start following the firmware upgrade instructions from Cineform. Let’s assume it’s installed.
http://gopro.com/support/hd-hero2-firmware-update

Check the link to the PDF instructions.
http://d3m6eq123hajy2.cloudfront.net...structions.pdf


This is where things can get interesting.
If you are lucky the full upgrade to ‘622’ will proceed.
I wasn’t lucky.
The firmware was downloaded and placed on the SD card, but the Hero2 was not restarting and installing the upgrade.

Getting the Hero 2 to take the firmware upgrade needed an unsupported procedure which I found here


Even this example isn’t exactly what I experienced. The video shows a v70 upgrade, I did see this, followed by a v622 upgrade. I also had to try a couple of times to get the Hero 2 two switch on with the ‘S’ button pressed.

The good news (so far) is that the Hero2 is now on ‘622’ and will switch on/off reliably and I managed to do a time lapse session successfully this afternoon. Normal service appears to have resumed.

I had reached the point where I was checking the Amazon return procedure and was ready to start explaining to them that even if the Hero2 had been bought months back it was barely used and my deal was with them not GoPro support in the USA.

The final lesson out of this is that *GoPro should be documenting the update process*, including the less than happy paths and supporting them, not leaving customers to hope that someone on Youtube has an answer.
If the camera had been sent back (i.e. I hadn’t persevered or stumbled on useful advice) I would not have taken a replacement and would have spent another 8 hours letting anyone who bothered to read reviews how unreliable I thought the Hero2 was.

Last edited by _sinistral; 05-26-2013 at 06:12 PM. Reason: formatting and a typo
_sinistral is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the GoPro Forum, Classifieds and Support forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Charge GoPro 3 on-the-road? cd_ GoPro HD Hero 3 7 01-20-2013 06:18 PM
how many hours to charge my battery kw19791 GoPro HD Hero 3 6 01-01-2013 10:47 PM
GoPro won't turn on or charge. iMgasam GoPro HD Hero 3 1 12-28-2012 02:07 PM
constant charge/continuous charge... why are there no accessories for this??! cfowler GoPro HD Hero and Hero 2 0 08-05-2012 05:51 AM
HD Hero 2 not holding charge. Help! Jasper Ash GoPro HD Hero and Hero 2 0 08-04-2012 04:56 PM

» Recent Threads
GoPro Intros
Yesterday 07:41 PM
Last post by fishycomics
Yesterday 07:41 PM
0 Replies, 52 Views
GoPro Hero 3+ Black -...
Yesterday 03:57 PM
Last post by Dooiedibbes
Yesterday 05:39 PM
3 Replies, 74 Views
Recording Length Question
08-28-2014 08:41 AM
Last post by fishycomics
Yesterday 04:30 PM
7 Replies, 328 Views
GoPro Mounting & General...
11-29-2013 12:12 PM
by Ifti
Last post by Ifti
Yesterday 03:54 PM
8 Replies, 1,746 Views
GO PRO Video Of the...
07-27-2014 07:51 AM
Last post by fishycomics
Yesterday 06:40 AM
10 Replies, 569 Views
Photo of the month for...
08-30-2014 08:35 PM
Last post by X5rdman
Yesterday 12:20 AM
2 Replies, 57 Views
Hi People
08-30-2014 05:40 PM
Last post by fishycomics
08-30-2014 05:58 PM
2 Replies, 64 Views
HDMI not works
08-30-2014 11:59 AM
by kel
Last post by Ifti
08-30-2014 04:46 PM
2 Replies, 154 Views
HGVBEST Waterproof case...
08-30-2014 01:32 PM
Last post by fishycomics
08-30-2014 01:32 PM
0 Replies, 51 Views
Smatree Smapole S1...
08-29-2014 06:50 PM
Last post by fishycomics
08-30-2014 10:09 AM
2 Replies, 76 Views
Mac can't read card
08-29-2014 09:19 AM
by nogo
Last post by nogo
08-30-2014 06:31 AM
1 Replies, 66 Views
Watersport edit + HELP
08-29-2014 05:18 PM
by Hland98
Last post by Hland98
08-29-2014 05:18 PM
0 Replies, 105 Views
Water Sports
08-29-2014 04:45 PM
Last post by jacobpratt32
08-29-2014 04:45 PM
0 Replies, 144 Views
How to watch video on...
08-29-2014 10:27 AM
by Justfly
Last post by Ifti
08-29-2014 04:14 PM
1 Replies, 148 Views
DJI Phantom 1 + Gopro...
08-29-2014 02:31 AM
Last post by pk-studio
08-29-2014 02:31 AM
0 Replies, 92 Views
VIDEO...
06-22-2014 05:16 PM
by Ifti
Last post by Ifti
08-28-2014 05:04 PM
18 Replies, 837 Views
Windows phone 8.1 &...
08-28-2014 04:33 PM
Last post by Big Kev2
08-28-2014 04:33 PM
0 Replies, 83 Views
Hi from a Shropshire...
08-28-2014 03:47 PM
Last post by fishycomics
08-28-2014 04:15 PM
1 Replies, 156 Views
Just Joined
08-28-2014 07:18 AM
Last post by Ifti
08-28-2014 03:09 PM
1 Replies, 94 Views
Riding the Golden Gate...
08-28-2014 09:03 AM
by jerrykr
Last post by fishycomics
08-28-2014 12:01 PM
3 Replies, 102 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 03:26 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0 PL3
User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.